hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11875) [JDK9] Renaming _ as a one-character identifier to another identifier
Date Fri, 03 Mar 2017 12:11:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11875?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15894233#comment-15894233

Steve Loughran commented on HADOOP-11875:

Looking at this. We'll have to get the yarn & MR projects to review, as they are the main

otherwise, I don't think the new package should be "hamlet4java9"; many decades in the future,
having a "java9" reference will seem quaint in stack traces. Just call it "hamlet2"

> [JDK9] Renaming _ as a one-character identifier to another identifier
> ---------------------------------------------------------------------
>                 Key: HADOOP-11875
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11875
>             Project: Hadoop Common
>          Issue Type: Bug
>            Reporter: Tsuyoshi Ozawa
>            Assignee: Akira Ajisaka
>              Labels: webapp
>         Attachments: build_error_dump.txt, HADOOP-11875.01.patch, HADOOP-11875.02.patch,
> From JDK9, _ as a one-character identifier is banned. Currently Web UI uses it. We should
fix them to compile with JDK9. https://bugs.openjdk.java.net/browse/JDK-8061549

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org

View raw message