hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsuyoshi Ozawa (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HADOOP-10101) Update guava dependency to the latest version
Date Tue, 14 Mar 2017 12:07:42 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10101?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15924069#comment-15924069
] 

Tsuyoshi Ozawa edited comment on HADOOP-10101 at 3/14/17 12:07 PM:
-------------------------------------------------------------------

I would like to resume working on this jira, based on shading approach as Nicholas and Hitesh
mentioned. Please give me to try the approach for a few days.

{quote}
why version 18 and not 19? Guava 19 was released in 2015 or so
{quote}

It's because Guava 19 had more incompatible change. Now, 21.0, which requires JDK-8 or upper,
has been released. I would like to create a patch to update Guava's version to 21.0, targeting
branch-3.

{quote}
have you confirmed that no deprecated and/or beta apis are being used?
{quote}

Not yet. 

{quote}
I believe there are some places where guava objects are being used in public facing APIs.
This might not be something to address in this jira but should definitely be looked at as
a blocker before the next release in addition to my initial comment.
{quote}

Yeah, let's do this on another jira. I think we should create this wrapper class instead of
exposing Guava's objects directly.

{quote}
I did try a quick prototype approach on branch-2 and it seems to function without directly
pulling in guava ( except of course - the curator guava dependency problem )
{quote}

Curator have also shared Guava. If we can move the version to up to date version, we can avoid
the problem. 


was (Author: ozawa):
I would like to resume working on this jira, based on shading approach as Nicholas and Hitesh
mentioned. Please give me to try for a few days.

{quote}
why version 18 and not 19? Guava 19 was released in 2015 or so
{quote}

It's because Guava 19 had more incompatible change. Now, 21.0, which requires JDK-8 or upper,
has been released. I would like to create a patch to update Guava's version to 21.0, targeting
branch-3.

{quote}
have you confirmed that no deprecated and/or beta apis are being used?
{quote}

Not yet. 

{quote}
I believe there are some places where guava objects are being used in public facing APIs.
This might not be something to address in this jira but should definitely be looked at as
a blocker before the next release in addition to my initial comment.
{quote}

Yeah, let's do this on another jira. I think we should create this wrapper class instead of
exposing Guava's objects directly.

{quote}
I did try a quick prototype approach on branch-2 and it seems to function without directly
pulling in guava ( except of course - the curator guava dependency problem )
{quote}

Curator have also shared Guava. If we can move the version to up to date version, we can avoid
the problem. 

> Update guava dependency to the latest version
> ---------------------------------------------
>
>                 Key: HADOOP-10101
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10101
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 2.2.0, 2.6.0
>            Reporter: Rakesh R
>            Assignee: Tsuyoshi Ozawa
>              Labels: BB2015-05-TBR
>         Attachments: HADOOP-10101-002.patch, HADOOP-10101-004.patch, HADOOP-10101-005.patch,
HADOOP-10101-006.patch, HADOOP-10101-007.patch, HADOOP-10101-008.patch, HADOOP-10101-009.patch,
HADOOP-10101-009.patch, HADOOP-10101-010.patch, HADOOP-10101-010.patch, HADOOP-10101-011.patch,
HADOOP-10101.patch, HADOOP-10101.patch
>
>
> The existing guava version is 11.0.2 which is quite old. This 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message