hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Zhuge (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-14038) Add ADLS credential properties to core-default.xml
Date Thu, 23 Feb 2017 21:48:44 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-14038?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15881342#comment-15881342

John Zhuge commented on HADOOP-14038:

Probably a carryover of the old WebHDFS mindset. Since HADOOP-13037 rewrote the connector
as an independent FileSystem, we should rename all {{dfs.adls.}} prefix to {{fs.adl.}}

 I am ok to do the substitutions in this JIRA. And rename {{adl.dfs.enable.client.latency.tracker}}
to {{adl.enable.client.latency.tracker}}.

 [~vishwajeet.dusane] and [~ASikaria], what do you think?

> Add ADLS credential properties to core-default.xml
> --------------------------------------------------
>                 Key: HADOOP-14038
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14038
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs/adl
>    Affects Versions: 3.0.0-alpha3
>            Reporter: John Zhuge
>            Assignee: John Zhuge
>            Priority: Minor
>         Attachments: HADOOP-14038.001.patch, HADOOP-14038.002.patch, HADOOP-14038.003.patch
> Add ADLS credential configuration properties to {{core-default.xml}}. Set/document the
default value for {{dfs.adls.oauth2.access.token.provider.type}} to {{ClientCredential}}.
> Fix {{AdlFileSystem#getAccessTokenProvider}} which implies the provider type is {{Custom}}.
> Fix several unit tests that set {{dfs.adls.oauth2.access.token.provider}} but does not
set {{dfs.adls.oauth2.access.token.provider.type}}.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org

View raw message