hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11875) [JDK9] Renaming _ as a one-character identifier to another identifier
Date Mon, 06 Feb 2017 11:57:41 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11875?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15853886#comment-15853886
] 

Steve Loughran commented on HADOOP-11875:
-----------------------------------------

you have to treat anything marked as limited private "mapreduce" as "something you need whenever
writing any yarn app". If you look at even the dshell example, it pulls in lots of stuff like
that —so no, that marker doesn't give you the freedom to do it.

> [JDK9] Renaming _ as a one-character identifier to another identifier
> ---------------------------------------------------------------------
>
>                 Key: HADOOP-11875
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11875
>             Project: Hadoop Common
>          Issue Type: Bug
>            Reporter: Tsuyoshi Ozawa
>            Assignee: Akira Ajisaka
>              Labels: webapp
>         Attachments: build_error_dump.txt, HADOOP-11875.01.patch
>
>
> From JDK9, _ as a one-character identifier is banned. Currently Web UI uses it. We should
fix them to compile with JDK9. https://bugs.openjdk.java.net/browse/JDK-8061549



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message