hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13816) Ambiguous plugin version warning from maven build.
Date Tue, 15 Nov 2016 09:27:59 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13816?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15666639#comment-15666639
] 

Hadoop QA commented on HADOOP-13816:
------------------------------------

| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | {color:blue} reexec {color} | {color:blue}  0m 14s{color} | {color:blue}
Docker mode activated. {color} |
| {color:green}+1{color} | {color:green} @author {color} | {color:green}  0m  0s{color} |
{color:green} The patch does not contain any @author tags. {color} |
| {color:red}-1{color} | {color:red} test4tests {color} | {color:red}  0m  0s{color} | {color:red}
The patch doesn't appear to include any new or modified tests. Please justify why no new tests
are needed for this patch. Also please list what manual steps were performed to verify this
patch. {color} |
| {color:blue}0{color} | {color:blue} mvndep {color} | {color:blue}  0m 15s{color} | {color:blue}
Maven dependency ordering for branch {color} |
| {color:green}+1{color} | {color:green} mvninstall {color} | {color:green}  6m 45s{color}
| {color:green} trunk passed {color} |
| {color:green}+1{color} | {color:green} compile {color} | {color:green}  9m 29s{color} |
{color:green} trunk passed {color} |
| {color:green}+1{color} | {color:green} mvnsite {color} | {color:green}  9m 31s{color} |
{color:green} trunk passed {color} |
| {color:green}+1{color} | {color:green} mvneclipse {color} | {color:green}  1m  5s{color}
| {color:green} trunk passed {color} |
| {color:green}+1{color} | {color:green} javadoc {color} | {color:green}  4m 19s{color} |
{color:green} trunk passed {color} |
| {color:blue}0{color} | {color:blue} mvndep {color} | {color:blue}  0m 16s{color} | {color:blue}
Maven dependency ordering for patch {color} |
| {color:green}+1{color} | {color:green} mvninstall {color} | {color:green}  7m 12s{color}
| {color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} compile {color} | {color:green}  9m 14s{color} |
{color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} javac {color} | {color:green}  9m 14s{color} | {color:green}
the patch passed {color} |
| {color:green}+1{color} | {color:green} mvnsite {color} | {color:green}  9m 28s{color} |
{color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} mvneclipse {color} | {color:green}  1m  5s{color}
| {color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} whitespace {color} | {color:green}  0m  0s{color}
| {color:green} The patch has no whitespace issues. {color} |
| {color:green}+1{color} | {color:green} xml {color} | {color:green}  0m  4s{color} | {color:green}
The patch has no ill-formed XML file. {color} |
| {color:green}+1{color} | {color:green} javadoc {color} | {color:green}  4m 22s{color} |
{color:green} the patch passed {color} |
| {color:red}-1{color} | {color:red} unit {color} | {color:red} 45m 33s{color} | {color:red}
root in the patch failed. {color} |
| {color:red}-1{color} | {color:red} asflicense {color} | {color:red}  0m 31s{color} | {color:red}
The patch generated 2 ASF License warnings. {color} |
| {color:black}{color} | {color:black} {color} | {color:black}110m  9s{color} | {color:black}
{color} |
\\
\\
|| Reason || Tests ||
| Failed junit tests | hadoop.crypto.key.kms.server.TestKMS |
\\
\\
|| Subsystem || Report/Notes ||
| Docker |  Image:yetus/hadoop:a9ad5d6 |
| JIRA Issue | HADOOP-13816 |
| JIRA Patch URL | https://issues.apache.org/jira/secure/attachment/12838744/HADOOP-13816.01.patch
|
| Optional Tests |  asflicense  compile  javac  javadoc  mvninstall  mvnsite  unit  xml  |
| uname | Linux 3eb3bcf49c97 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12
UTC 2014 x86_64 x86_64 x86_64 GNU/Linux |
| Build tool | maven |
| Personality | /testptch/hadoop/patchprocess/precommit/personality/provided.sh |
| git revision | trunk / b7070f3 |
| Default Java | 1.8.0_101 |
| unit | https://builds.apache.org/job/PreCommit-HADOOP-Build/11066/artifact/patchprocess/patch-unit-root.txt
|
|  Test Results | https://builds.apache.org/job/PreCommit-HADOOP-Build/11066/testReport/ |
| asflicense | https://builds.apache.org/job/PreCommit-HADOOP-Build/11066/artifact/patchprocess/patch-asflicense-problems.txt
|
| modules | C: hadoop-build-tools hadoop-tools/hadoop-rumen . U: . |
| Console output | https://builds.apache.org/job/PreCommit-HADOOP-Build/11066/console |
| Powered by | Apache Yetus 0.4.0-SNAPSHOT   http://yetus.apache.org |


This message was automatically generated.



> Ambiguous plugin version warning from maven build.
> --------------------------------------------------
>
>                 Key: HADOOP-13816
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13816
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Kai Sasaki
>            Assignee: Kai Sasaki
>            Priority: Minor
>         Attachments: HADOOP-13816.01.patch
>
>
> When we try to build Hadoop with maven, the below warning is shown.
> {code}
> [WARNING]
> [WARNING] Some problems were encountered while building the effective model for org.apache.hadoop:hadoop-rumen:jar:3.0.0-alpha2-SNAPSHOT
> [WARNING] 'dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique:
com.fasterxml.jackson.core:jackson-databind:jar -> duplicate declaration of version (?)
@ line 102, column 17
> [WARNING]
> [WARNING] Some problems were encountered while building the effective model for org.apache.hadoop:hadoop-build-tools:jar:3.0.0-alpha2-SNAPSHOT
> [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-remote-resources-plugin
is missing. @ org.apache.hadoop:hadoop-build-tools:[unknown-version], /Users/sasakikai/dev/hadoop/hadoop-build-tools/pom.xml,
line 80, column 15
> [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-resources-plugin
is missing. @ org.apache.hadoop:hadoop-build-tools:[unknown-version], /Users/sasakikai/dev/hadoop/hadoop-build-tools/pom.xml,
line 54, column 15
> {code}
> It is required to 
> - remove duplicated definition {{jackson-databind}}
> - specify the version {{maven-resource-plugin}} and {{maven-remote-resources-plugin}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message