hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mingliang Liu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13050) Upgrade to AWS SDK 10.11+
Date Tue, 22 Nov 2016 21:04:58 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13050?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15687889#comment-15687889
] 

Mingliang Liu commented on HADOOP-13050:
----------------------------------------

[~stevel@apache.org] no worries. The target branch is both {{branch-2}} and {{tunk}} so we
have to provide a similar {{branch-2}} patch as well. Fortunately our patches are exactly
the same with just one line of new break. So I guess you just +1 on this patch? If we should
thank Chris for original patch, should I use "contributed by Chris and Steve" when committing?

One last concern from the Jenkins run is that, [HADOOP-13727] added the {{SharedInstanceProfileCredentialsProvider}},
which can be removed after this AWS SDK upgrade. Do you think we address it here, or separately?
Chris also mentioned this in the JIRA:
{quote}
As of AWS SDK 1.11.39, the SDK code internally enforces a singleton. After Hadoop upgrades
to that version or higher, it's likely that we can remove this code.
{quote}


> Upgrade to AWS SDK 10.11+
> -------------------------
>
>                 Key: HADOOP-13050
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13050
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: build, fs/s3
>    Affects Versions: 2.7.2
>            Reporter: Steve Loughran
>            Assignee: Steve Loughran
>            Priority: Blocker
>         Attachments: HADOOP-13050-001.patch, HADOOP-13050-002.patch, HADOOP-13050-branch-2-003.patch,
HADOOP-13050-branch-2-004.patch, HADOOP-13050-branch-2.002.patch, HADOOP-13050-branch-2.003.patch
>
>
> HADOOP-13044 highlights that AWS SDK 10.6 —shipping in Hadoop 2.7+, doesn't work on
open jdk >= 8u60, because a change in the JDK broke the version of Joda time that AWS uses.
> Fix, update the JDK. Though, that implies updating http components: HADOOP-12767.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message