hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harsh J (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-6801) io.sort.mb and io.sort.factor were renamed and moved to mapreduce but are still in CommonConfigurationKeysPublic.java and used in SequenceFile.java
Date Tue, 01 Nov 2016 13:41:58 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-6801?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15625461#comment-15625461
] 

Harsh J commented on HADOOP-6801:
---------------------------------

- Updated patch addresses the checkstyle issues

> io.sort.mb and io.sort.factor were renamed and moved to mapreduce but are still in CommonConfigurationKeysPublic.java
and used in SequenceFile.java
> ---------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-6801
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6801
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 0.22.0
>            Reporter: Erik Steffl
>            Assignee: Harsh J
>            Priority: Minor
>         Attachments: HADOOP-6801.05.patch, HADOOP-6801.r1.diff, HADOOP-6801.r2.diff,
HADOOP-6801.r3.diff, HADOOP-6801.r4.diff, HADOOP-6801.r5.diff
>
>
> Following configuration keys in CommonConfigurationKeysPublic.java (former CommonConfigurationKeys.java):
> public static final String  IO_SORT_MB_KEY = "io.sort.mb";
> public static final String  IO_SORT_FACTOR_KEY = "io.sort.factor";
> are partially moved:
>   - they were renamed to mapreduce.task.io.sort.mb and mapreduce.task.io.sort.factor
respectively
>   - they were moved to mapreduce project, documented in mapred-default.xml
> However:
>   - they are still listed in CommonConfigurationKeysPublic.java as quoted above
>   - strings "io.sort.mb" and "io.sort.factor" are used in SequenceFile.java in Hadoop
Common project
> Not sure what the solution is, these constants should probably be removed from CommonConfigurationKeysPublic.java
but I am not sure what's the best solution for SequenceFile.java.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message