hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiaoyu Yao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13686) Adding additional unit test for Trash (I)
Date Tue, 11 Oct 2016 18:32:20 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13686?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15566194#comment-15566194

Xiaoyu Yao commented on HADOOP-13686:

Thanks [~cheersyang] for the update. patch v3 looks good to me. Two remaining issues:
1. We need leave the change of TestHDFSTrash.java in HDFS-10922.
2. Address the Jenkins failures in testTrashPermission.

I don't think HDFS-10922 will use AuditableTrashPolicy/AuditableCheckpoints, they are helper
classes to verify trash intervals in testTrashRestarts, I can't see how to reuse it in HDFS
trash tests. 

You are right. I proposed to reuse AuditableTrashPolicy/AuditableCheckpoints because the patch
v06 in HDFS-10922 has duplicated code at the time when I review this one. Now that you've
updated HDFS-10922. We don't need to address #4 now.  

bq. Regarding to #5, I used static AuditableCheckpoints and static vars, because I need to
share checkpoint states between multiple instances of trash policies while simulating restart,
I used atom integer to avoid thread safety problem.

Make sense to me.

> Adding additional unit test for Trash (I)
> -----------------------------------------
>                 Key: HADOOP-13686
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13686
>             Project: Hadoop Common
>          Issue Type: Test
>            Reporter: Xiaoyu Yao
>            Assignee: Weiwei Yang
>         Attachments: HADOOP-13686.01.patch, HADOOP-13686.02.patch, HADOOP-13686.03.patch
> This ticket is opened to track adding the forllowing unit test in hadoop-common. 
> #test users can delete their own trash directory
> #test users can delete an empty directory and the directory is moved to trash
> #test fs.trash.interval with invalid values such as 0 or negative

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org

View raw message