hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiaoyu Yao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13502) Rename/split fs.contract.is-blobstore flag used by contract tests.
Date Tue, 04 Oct 2016 20:13:20 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13502?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15546524#comment-15546524
] 

Xiaoyu Yao commented on HADOOP-13502:
-------------------------------------

Thanks [~cnauroth] for the update. Just one NIT: 
in AbstractContractCreateTest.java, can we remove the assumption of *object store* in the
comments and the skip message to match the description of the new flag, which should be applicable
to all HCFS? 

{code}
 // object store: downgrade to a skip so that the failure is visible
 // in test results
 skip("Filesystem is an object store and newly created files are not immediately visible");
{code}

> Rename/split fs.contract.is-blobstore flag used by contract tests.
> ------------------------------------------------------------------
>
>                 Key: HADOOP-13502
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13502
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>            Reporter: Chris Nauroth
>            Assignee: Chris Nauroth
>            Priority: Minor
>         Attachments: HADOOP-13502-branch-2.001.patch, HADOOP-13502-branch-2.002.patch
>
>
> The {{fs.contract.is-blobstore}} flag guards against execution of several contract tests
to account for known limitations with blob stores.  However, the name is not entirely accurate,
because it's still possible that a file system implemented against a blob store could pass
those tests, depending on whether or not the implementation matches the semantics of HDFS.
 This issue proposes to rename the flag or split it into different flags with different definitions
for the semantics covered by the current flag.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message