hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-13050) Upgrade to AWS SDK 10.10+ for Java 8u60+
Date Wed, 19 Oct 2016 22:20:58 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-13050?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Nauroth updated HADOOP-13050:
-----------------------------------
    Attachment: HADOOP-13050-branch-2.002.patch

This needed a rebase after one of my patches, so I went ahead and updated it.  I'm attaching
revision 002.  This time, I went to AWS SDK 1.11.45.  All tests passed against US-west-2.

Here is the updated dependency tree:
{code}
[INFO] --- maven-dependency-plugin:2.2:tree (default-cli) @ hadoop-aws ---
[INFO] org.apache.hadoop:hadoop-aws:jar:2.9.0-SNAPSHOT
[INFO] +- org.apache.hadoop:hadoop-common:jar:2.9.0-SNAPSHOT:compile
[INFO] |  +- org.apache.hadoop:hadoop-annotations:jar:2.9.0-SNAPSHOT:compile
[INFO] |  |  \- jdk.tools:jdk.tools:jar:1.7:system
[INFO] |  +- com.google.guava:guava:jar:11.0.2:compile
[INFO] |  +- commons-cli:commons-cli:jar:1.2:compile
[INFO] |  +- org.apache.commons:commons-math3:jar:3.1.1:compile
[INFO] |  +- xmlenc:xmlenc:jar:0.52:compile
[INFO] |  +- org.apache.httpcomponents:httpclient:jar:4.5.2:compile
[INFO] |  |  \- org.apache.httpcomponents:httpcore:jar:4.4.4:compile
[INFO] |  +- commons-codec:commons-codec:jar:1.4:compile
[INFO] |  +- commons-io:commons-io:jar:2.4:compile
[INFO] |  +- commons-net:commons-net:jar:3.1:compile
[INFO] |  +- commons-collections:commons-collections:jar:3.2.2:compile
[INFO] |  +- javax.servlet:servlet-api:jar:2.5:compile
[INFO] |  +- org.mortbay.jetty:jetty:jar:6.1.26:compile
[INFO] |  +- org.mortbay.jetty:jetty-util:jar:6.1.26:compile
[INFO] |  +- org.mortbay.jetty:jetty-sslengine:jar:6.1.26:compile
[INFO] |  +- javax.servlet.jsp:jsp-api:jar:2.1:runtime
[INFO] |  +- com.sun.jersey:jersey-core:jar:1.9:compile
[INFO] |  +- com.sun.jersey:jersey-json:jar:1.9:compile
[INFO] |  |  +- org.codehaus.jettison:jettison:jar:1.1:compile
[INFO] |  |  +- com.sun.xml.bind:jaxb-impl:jar:2.2.3-1:compile
[INFO] |  |  |  \- javax.xml.bind:jaxb-api:jar:2.2.2:compile
[INFO] |  |  |     +- javax.xml.stream:stax-api:jar:1.0-2:compile
[INFO] |  |  |     \- javax.activation:activation:jar:1.1:compile
[INFO] |  |  +- org.codehaus.jackson:jackson-jaxrs:jar:1.9.13:compile (version managed from
1.8.3)
[INFO] |  |  \- org.codehaus.jackson:jackson-xc:jar:1.9.13:compile (version managed from 1.8.3)
[INFO] |  +- com.sun.jersey:jersey-server:jar:1.9:compile
[INFO] |  |  \- asm:asm:jar:3.2:compile (version managed from 3.1)
[INFO] |  +- commons-logging:commons-logging:jar:1.1.3:compile
[INFO] |  +- log4j:log4j:jar:1.2.17:compile
[INFO] |  +- net.java.dev.jets3t:jets3t:jar:0.9.0:compile
[INFO] |  |  \- com.jamesmurty.utils:java-xmlbuilder:jar:0.4:compile
[INFO] |  +- commons-lang:commons-lang:jar:2.6:compile
[INFO] |  +- commons-configuration:commons-configuration:jar:1.6:compile
[INFO] |  |  +- commons-digester:commons-digester:jar:1.8:compile
[INFO] |  |  |  \- commons-beanutils:commons-beanutils:jar:1.7.0:compile
[INFO] |  |  \- commons-beanutils:commons-beanutils-core:jar:1.8.0:compile
[INFO] |  +- org.slf4j:slf4j-api:jar:1.7.10:compile
[INFO] |  +- org.codehaus.jackson:jackson-core-asl:jar:1.9.13:compile
[INFO] |  +- org.codehaus.jackson:jackson-mapper-asl:jar:1.9.13:compile
[INFO] |  +- org.apache.avro:avro:jar:1.7.4:compile
[INFO] |  |  +- com.thoughtworks.paranamer:paranamer:jar:2.3:compile
[INFO] |  |  \- org.xerial.snappy:snappy-java:jar:1.0.4.1:compile
[INFO] |  +- com.google.protobuf:protobuf-java:jar:2.5.0:compile
[INFO] |  +- com.google.code.gson:gson:jar:2.2.4:compile
[INFO] |  +- org.apache.hadoop:hadoop-auth:jar:2.9.0-SNAPSHOT:compile
[INFO] |  |  +- com.nimbusds:nimbus-jose-jwt:jar:3.9:compile
[INFO] |  |  |  +- net.jcip:jcip-annotations:jar:1.0:compile
[INFO] |  |  |  \- net.minidev:json-smart:jar:1.1.1:compile
[INFO] |  |  +- org.apache.directory.server:apacheds-kerberos-codec:jar:2.0.0-M15:compile
[INFO] |  |  |  +- org.apache.directory.server:apacheds-i18n:jar:2.0.0-M15:compile
[INFO] |  |  |  +- org.apache.directory.api:api-asn1-api:jar:1.0.0-M20:compile
[INFO] |  |  |  \- org.apache.directory.api:api-util:jar:1.0.0-M20:compile
[INFO] |  |  \- org.apache.curator:curator-framework:jar:2.7.1:compile
[INFO] |  +- com.jcraft:jsch:jar:0.1.51:compile
[INFO] |  +- org.apache.curator:curator-client:jar:2.7.1:compile
[INFO] |  +- org.apache.curator:curator-recipes:jar:2.7.1:compile
[INFO] |  +- com.google.code.findbugs:jsr305:jar:3.0.0:compile
[INFO] |  +- org.apache.htrace:htrace-core4:jar:4.0.1-incubating:compile
[INFO] |  +- org.apache.zookeeper:zookeeper:jar:3.4.6:compile
[INFO] |  |  +- org.slf4j:slf4j-log4j12:jar:1.7.10:compile (version managed from 1.6.1)
[INFO] |  |  \- io.netty:netty:jar:3.6.2.Final:compile (version managed from 3.7.0.Final)
[INFO] |  \- org.apache.commons:commons-compress:jar:1.4.1:compile
[INFO] |     \- org.tukaani:xz:jar:1.0:compile
[INFO] +- org.apache.hadoop:hadoop-common:test-jar:tests:2.9.0-SNAPSHOT:test
[INFO] +- com.amazonaws:aws-java-sdk-s3:jar:1.11.45:compile
[INFO] |  +- com.amazonaws:aws-java-sdk-kms:jar:1.11.45:compile
[INFO] |  +- com.amazonaws:aws-java-sdk-core:jar:1.11.45:compile
[INFO] |  |  \- software.amazon.ion:ion-java:jar:1.0.1:compile
[INFO] |  \- com.amazonaws:jmespath-java:jar:1.0:compile
[INFO] +- com.fasterxml.jackson.core:jackson-core:jar:2.6.6:compile
[INFO] +- com.fasterxml.jackson.core:jackson-databind:jar:2.6.6:compile
[INFO] +- com.fasterxml.jackson.core:jackson-annotations:jar:2.6.6:compile
[INFO] +- com.fasterxml.jackson.dataformat:jackson-dataformat-cbor:jar:2.6.6:compile
[INFO] +- joda-time:joda-time:jar:2.9.4:compile
[INFO] +- com.amazonaws:aws-java-sdk-sts:jar:1.11.45:test
[INFO] +- junit:junit:jar:4.11:test
[INFO] |  \- org.hamcrest:hamcrest-core:jar:1.3:test
[INFO] +- org.mockito:mockito-all:jar:1.8.5:test
[INFO] +- org.apache.hadoop:hadoop-mapreduce-client-jobclient:jar:2.9.0-SNAPSHOT:test
[INFO] |  +- org.apache.hadoop:hadoop-mapreduce-client-common:jar:2.9.0-SNAPSHOT:test
[INFO] |  |  +- org.apache.hadoop:hadoop-yarn-client:jar:2.9.0-SNAPSHOT:test
[INFO] |  |  \- org.apache.hadoop:hadoop-mapreduce-client-core:jar:2.9.0-SNAPSHOT:test
[INFO] |  +- org.apache.hadoop:hadoop-mapreduce-client-shuffle:jar:2.9.0-SNAPSHOT:test
[INFO] |  |  \- org.fusesource.leveldbjni:leveldbjni-all:jar:1.8:test
[INFO] |  \- com.google.inject.extensions:guice-servlet:jar:3.0:test
[INFO] |     \- com.google.inject:guice:jar:3.0:test
[INFO] |        +- javax.inject:javax.inject:jar:1:test
[INFO] |        \- aopalliance:aopalliance:jar:1.0:test
[INFO] +- org.apache.hadoop:hadoop-yarn-server-tests:test-jar:tests:2.9.0-SNAPSHOT:test
[INFO] |  +- org.apache.hadoop:hadoop-yarn-server-common:jar:2.9.0-SNAPSHOT:test
[INFO] |  +- org.apache.hadoop:hadoop-yarn-server-nodemanager:jar:2.9.0-SNAPSHOT:test
[INFO] |  |  +- com.sun.jersey:jersey-client:jar:1.9:test
[INFO] |  |  +- com.codahale.metrics:metrics-core:jar:3.0.1:test
[INFO] |  |  \- com.sun.jersey.contribs:jersey-guice:jar:1.9:test
[INFO] |  +- org.apache.hadoop:hadoop-yarn-server-resourcemanager:jar:2.9.0-SNAPSHOT:test
[INFO] |  |  +- org.apache.hadoop:hadoop-yarn-server-applicationhistoryservice:jar:2.9.0-SNAPSHOT:test
[INFO] |  |  |  \- de.ruedigermoeller:fst:jar:2.24:test
[INFO] |  |  |     \- org.objenesis:objenesis:jar:2.1:test
[INFO] |  |  +- org.apache.hadoop:hadoop-yarn-server-web-proxy:jar:2.9.0-SNAPSHOT:test
[INFO] |  |  +- org.apache.curator:curator-test:jar:2.7.1:test
[INFO] |  |  |  +- org.javassist:javassist:jar:3.18.1-GA:test
[INFO] |  |  |  \- org.apache.commons:commons-math:jar:2.2:test
[INFO] |  |  \- org.apache.zookeeper:zookeeper:test-jar:tests:3.4.6:test
[INFO] |  +- org.apache.hadoop:hadoop-yarn-common:jar:2.9.0-SNAPSHOT:test
[INFO] |  \- org.apache.hadoop:hadoop-yarn-api:jar:2.9.0-SNAPSHOT:test
[INFO] +- org.apache.hadoop:hadoop-mapreduce-examples:jar:2.9.0-SNAPSHOT:test
[INFO] |  \- org.apache.hadoop:hadoop-hdfs-client:jar:2.9.0-SNAPSHOT:test
[INFO] |     \- com.squareup.okhttp:okhttp:jar:2.4.0:test
[INFO] |        \- com.squareup.okio:okio:jar:1.4.0:test
[INFO] +- org.apache.hadoop:hadoop-distcp:jar:2.9.0-SNAPSHOT:test
[INFO] \- org.apache.hadoop:hadoop-distcp:test-jar:tests:2.9.0-SNAPSHOT:test
{code}


> Upgrade to AWS SDK 10.10+ for Java 8u60+
> ----------------------------------------
>
>                 Key: HADOOP-13050
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13050
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: build, fs/s3
>    Affects Versions: 2.7.2
>            Reporter: Steve Loughran
>         Attachments: HADOOP-13050-001.patch, HADOOP-13050-branch-2.002.patch
>
>
> HADOOP-13044 highlights that AWS SDK 10.6 —shipping in Hadoop 2.7+, doesn't work on
open jdk >= 8u60, because a change in the JDK broke the version of Joda time that AWS uses.
> Fix, update the JDK. Though, that implies updating http components: HADOOP-12767.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message