hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen Liang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-13658) Replace config key literal string with the name of the keys in o.a.h.i.f.t.Compression
Date Mon, 26 Sep 2016 17:34:20 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-13658?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chen Liang updated HADOOP-13658:
--------------------------------
    Description: 
There are several places in o.a.h.i.f.t.Compression where the config keys are used by the
literal strings instead of their names as in configuration key classes. For example

{code}
conf.setInt("io.compression.codec.lzo.buffersize", 64 * 1024);
{code}

should be

{code}
conf.setInt(CommonConfigurationKeys.IO_COMPRESSION_CODEC_LZO_BUFFERSIZE_KEY, 64 * 1024);
{code}

instead

  was:
There are several places in o.a.h.i.f.t.Compression where the config keys are used by the
literal strings instead of their names as in configuration key classes. For example

{code}
conf.setInt("io.compression.codec.lzo.buffersize", 64 * 1024);
{code}

should be

{code}
conf.setInt(      CommonConfigurationKeys.IO_COMPRESSION_CODEC_LZO_BUFFERSIZE_KEY, 64 * 1024);
{code}

instead


> Replace config key literal string with the name of the keys in o.a.h.i.f.t.Compression
> --------------------------------------------------------------------------------------
>
>                 Key: HADOOP-13658
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13658
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: conf
>            Reporter: Chen Liang
>            Assignee: Chen Liang
>            Priority: Minor
>
> There are several places in o.a.h.i.f.t.Compression where the config keys are used by
the literal strings instead of their names as in configuration key classes. For example
> {code}
> conf.setInt("io.compression.codec.lzo.buffersize", 64 * 1024);
> {code}
> should be
> {code}
> conf.setInt(CommonConfigurationKeys.IO_COMPRESSION_CODEC_LZO_BUFFERSIZE_KEY, 64 * 1024);
> {code}
> instead



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message