hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen Liang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13644) Replace config key literal strings with config key names
Date Fri, 23 Sep 2016 20:40:20 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13644?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15517512#comment-15517512
] 

Chen Liang commented on HADOOP-13644:
-------------------------------------

I did some checking and it turns out there are actually a lot of usages like this in different
modules. Based on some offline discussion with [~liuml07], we decided to fix them in a step-by-step
fashion. Here the v001 patch only tries to resolve the use of {{"io.file.buffer.size"}} in
hadoop-commons. Will file other JIRAs to solve other usages like such.

> Replace config key literal strings with config key names 
> ---------------------------------------------------------
>
>                 Key: HADOOP-13644
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13644
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: conf
>            Reporter: Mingliang Liu
>            Assignee: Chen Liang
>            Priority: Minor
>         Attachments: HADOOP-13644.001.patch
>
>
> There are some places that use config key literal strings instead of config key names,
e.g.
> {code:title=IOUtils.java}
>     copyBytes(in, out, conf.getInt("io.file.buffer.size", 4096), true);
> {code}
> We should replace places like this.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message