hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-13502) Rename/split fs.contract.is-blobstore flag used by contract tests.
Date Tue, 16 Aug 2016 20:42:20 GMT
Chris Nauroth created HADOOP-13502:
--------------------------------------

             Summary: Rename/split fs.contract.is-blobstore flag used by contract tests.
                 Key: HADOOP-13502
                 URL: https://issues.apache.org/jira/browse/HADOOP-13502
             Project: Hadoop Common
          Issue Type: Improvement
          Components: test
            Reporter: Chris Nauroth
            Priority: Minor


The {{fs.contract.is-blobstore}} flag guards against execution of several contract tests to
account for known limitations with blob stores.  However, the name is not entirely accurate,
because it's still possible that a file system implemented against a blob store could pass
those tests, depending on whether or not the implementation matches the semantics of HDFS.
 This issue proposes to rename the flag or split it into different flags with different definitions
for the semantics covered by the current flag.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message