hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13430) Optimize and fix getFileStatus in S3A
Date Thu, 18 Aug 2016 13:20:21 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13430?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15426425#comment-15426425

Steve Loughran commented on HADOOP-13430:

Steven —I'm afraid all the HADOOP-13208 changes have touched getFileStatus enough that this
patch won't apply.

could you sync this up with trunk/branch-2, then use the naming scheme HADOOP-13430-branch-2-001.patch,
or HADOOP-13430-001.path for trunk...that way Yetus will apply and build the right version.

# I wouldn't use {{sillyCase()}} as a method name, something like {{getMetadata()}}
# there's a lot of translation of exceptions there; maybe it's time to split {{getFileStatus()}}
into the public method and an {{innerGetFileStatus()}} which doesn't do any translation (though
it will need to catch AmazonServiceException & swallow 404's, rethrowing anything else

> Optimize and fix getFileStatus in S3A
> -------------------------------------
>                 Key: HADOOP-13430
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13430
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs/s3
>    Affects Versions: 2.8.0
>            Reporter: Steven K. Wong
>            Assignee: Steven K. Wong
>            Priority: Minor
>         Attachments: HADOOP-13430.001.WIP.patch
> Currently, S3AFileSystem.getFileStatus(Path f) sends up to 3 requests to S3 when pathToKey(f)
= key = "foo/bar" is a directory:
> 1. HEAD key=foo/bar \[continue if not found]
> 2. HEAD key=foo/bar/ \[continue if not found]
> 3. LIST prefix=foo/bar/ delimiter=/ max-keys=1
> My experience (and generally true, I reckon) is that almost all directories are nonempty
directories without a "fake directory" file (e.g. "foo/bar/"). Under this condition, request
#2 is mostly unhelpful; it only slows down getFileStatus. Therefore, I propose swapping the
order of requests #2 and #3. The swapped HEAD request will be skipped in practically all cases.
> Furthermore, when key = "foo/bar" is a nonempty directory that contains a "fake directory"
file (in addition to actual files), getFileStatus currently returns an S3AFileStatus with
isEmptyDirectory=true, which is wrong. Swapping will fix this. The swapped LIST request will
use max-keys=2 to determine isEmptyDirectory correctly. (Removing the delimiter from the LIST
request should make the logic a little simpler than otherwise.)
> Note that key = "foo/bar/" has the same problem with isEmptyDirectory. To fix it, I propose
skipping request #1 when key ends with "/". The price is this will, for an empty directory,
replace a HEAD request with a LIST request that's generally more taxing on S3.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org

View raw message