hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anu Engineer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13248) Pre-Commit Docker Image build failures
Date Thu, 09 Jun 2016 01:06:21 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15321738#comment-15321738
] 

Anu Engineer commented on HADOOP-13248:
---------------------------------------

Thank you for the update. I appreciate it. I agree that it does look like network issue.
 Any suggestions on how we can get this fixed / reduce the incidence of this during builds
?  

> Pre-Commit Docker Image build failures
> --------------------------------------
>
>                 Key: HADOOP-13248
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13248
>             Project: Hadoop Common
>          Issue Type: Bug
>            Reporter: Anu Engineer
>            Priority: Critical
>
> Following emails threads from dev mailing lists explains the problem.
> I'm curious if anyone has noticed issues with pre-commit failing during the Docker image
build on Jenkins node H2.  Here are a few examples.
> https://builds.apache.org/job/PreCommit-HADOOP-Build/9661/console
> https://builds.apache.org/job/PreCommit-HADOOP-Build/9662/console
> https://builds.apache.org/job/PreCommit-HADOOP-Build/9670/console
> These are all test runs for the same patch, but the patch just removes 5 lines of Java
code, so I don't expect the particular patch could cause a failure like this.  I noticed that
they all ran on H2.  It seems to be a problem installing oracle-java8-installer:
> WARNING: The following packages cannot be authenticated!
>   oracle-java8-installer
> ?[91mE: There are problems and -y was used without --force-yes
> ?[0mThe command '/bin/sh -c apt-get -q install --no-install-recommends -y oracle-java8-installer'
returned a non-zero code: 100
> --Chris Nauroth
> ---------
> Thanks for bringing this up. I just ran into the same issue.
> https://builds.apache.org/job/PreCommit-HDFS-Build/15700/console
> But in my case it seems like a different host.  “Building remotely on H0”.
> --Anu
> ------
> Another instance of the same failure.
> https://builds.apache.org/job/PreCommit-HADOOP-Build/9690/console
> I am going to open a JIRA so that we can track this issue there. This is on H1 so I don’t
think it is machine specific.
> --Anu



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message