hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12160) Add snapshot APIs to the FileSystem specification
Date Wed, 29 Jun 2016 19:22:06 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12160?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15355698#comment-15355698

Steve Loughran commented on HADOOP-12160:

h3. {{filesystem.md}}


-what is current snapshot name isn't there?
-what if the destination snapshot name is already there?
-what if the dest name is illegal (e.g ".snapshot")


-what if the snapshot doesn't exist?

h3. {{model.md}}

line 279, change to "a valid path element"

h3. {{AbstractContractSnapshotTest}} : 

-{{ContractTestUtils.assertIsDirectory()}} may be better here.
-Don't think the {{createConfiguration()}} and {{teardown()}} method overrides are needed.

I think it'd be best to pull the check for a snapshot existing out into its own method, say
{{assertSnapshotExists(path, snapshotname)}}, so that if a filesystem ever implemented snapshots
it could do its own implementation. The HDFS one would build the path and use {{assertIsDirectory}}.

h3.  {{TestHDFSContractSnapshot}}

Is there any more detail on exception type other than IOE?

> Add snapshot APIs to the FileSystem specification
> -------------------------------------------------
>                 Key: HADOOP-12160
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12160
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: documentation, test
>    Affects Versions: 2.7.1
>            Reporter: Arpit Agarwal
>            Assignee: Masatake Iwasaki
>         Attachments: HADOOP-12160-branch-2.004.patch, HADOOP-12160-branch-2.005.patch,
HADOOP-12160.002.patch, HADOOP-12160.003.patch
> The following snapshot APIs should be documented in the [FileSystem specification|https://hadoop.apache.org/docs/current/hadoop-project-dist/hadoop-common/filesystem/filesystem.html].
> # createSnapshot(Path path)
> # createSnapshot(Path path, String snapshotName)
> # renameSnapshot(Path path, String snapshotOldName, String snapshotNewName)
> # deleteSnapshot(Path path, String snapshotName)

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org

View raw message