hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsuyoshi Ozawa (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12064) [JDK8] Update guice version to 4.0
Date Tue, 21 Jun 2016 06:47:57 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12064?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15341231#comment-15341231
] 

Tsuyoshi Ozawa commented on HADOOP-12064:
-----------------------------------------

I surveyed whether Guice 4.1.0 is acceptable for Hadoop: the answer is we cannot upgrade Guice
4.1.0 because it uses Guava 19.0.0. On the other hand, Guice 4.0.0 uses Guava 16.0.1, which
is acceptable version for Hadoop for now. 

Hence, I prefer 4.0.0 to 4.1.0 at this point. 

> [JDK8] Update guice version to 4.0
> ----------------------------------
>
>                 Key: HADOOP-12064
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12064
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Tsuyoshi Ozawa
>            Assignee: Tsuyoshi Ozawa
>              Labels: UpgradeKeyLibrary
>         Attachments: HADOOP-12064.001.patch, HADOOP-12064.002.WIP.patch
>
>
> guice 3.0 doesn't work with lambda statement. https://github.com/google/guice/issues/757
> We should upgrade it to 4.0 which includes the fix.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message