hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13200) Seeking a better approach allowing to customize and configure erasure coders
Date Wed, 25 May 2016 22:10:13 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15300964#comment-15300964
] 

Kai Zheng commented on HADOOP-13200:
------------------------------------

Copied partly [here | https://issues.apache.org/jira/browse/HADOOP-13010?focusedCommentId=15298587&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15298587]
by [~cmccabe]:
{quote}
I think these are really configuration questions, not questions about how the code should
be structured. What does the user actually need to configure? If the user just configures
a coder implementation, does that fully determine the codec which is being used? If so, we
should have only one configuration knob-- coder. If a coder could be used for multiple codecs,
then we need to have at least two knobs that the user can configure-- one for codec, and another
for coder. Once we know what the configuration knobs are, we probably only need one or two
functions to create the objects we need based on a Configuration object, not a whole mess
of factory objects.
{quote}

> Seeking a better approach allowing to customize and configure erasure coders
> ----------------------------------------------------------------------------
>
>                 Key: HADOOP-13200
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13200
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Kai Zheng
>            Assignee: Kai Zheng
>
> This is a follow-on task for HADOOP-13010 as discussed over there. There may be some
better approach allowing to customize and configure erasure coders than the current having
raw coder factory, as [~cmccabe] suggested. Will copy the relevant comments here to continue
the discussion.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message