hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12705) Upgrade Jackson 2.2.3 to 2.5.3 or later
Date Thu, 19 May 2016 15:01:13 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12705?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15291233#comment-15291233
] 

Steve Loughran commented on HADOOP-12705:
-----------------------------------------

We need to go to a later version of jackson so S3A works on Java 8u60+; HADOOP-13050 ... because
it needs an artifact {{com.fasterxml.jackson.dataformat:jackson-dataformat-cbor}} in sync
with jackson2, and it's 2.3.3 or later only.

> Upgrade Jackson 2.2.3 to 2.5.3 or later
> ---------------------------------------
>
>                 Key: HADOOP-12705
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12705
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: build
>    Affects Versions: 2.8.0
>            Reporter: Steve Loughran
>
> There's no rush to do this; this is just the JIRA to track versions. However, without
the upgrade, things written for Jackson 2.4.4 can break ( SPARK-12807)
> being Jackson, this is a potentially dangerous update.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message