hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun Singh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12987) HortonWorks Zeppelin issue in HDP 2.4
Date Tue, 05 Apr 2016 03:08:25 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12987?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15225575#comment-15225575
] 

Arun Singh commented on HADOOP-12987:
-------------------------------------

Hi Colin,

Understood. Please accept my apology for filing HortonWorks related issue at wrong place.


Thanks,
Arun

> HortonWorks Zeppelin issue in HDP 2.4
> -------------------------------------
>
>                 Key: HADOOP-12987
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12987
>             Project: Hadoop Common
>          Issue Type: Bug
>         Environment: SLES11 SP4
>            Reporter: Arun Singh
>            Assignee: Ali Bajwa
>
> Issue 2: Zeppelin. Zeppelin is a new component in Tech Preview in the latest HDP stack
(2.4). I've been following this guide: http://hortonworks.com/hadoop-tutorial/apache-zeppelin-hdp-2-4/
>    When installing Zeppelin through the Ambari interface, it errors out with a message
saying it can't install the package gcc-gfortran
>  
>    If you open the file: /var/lib/ambari-server/resources/stacks/HDP/2.4/services/ZEPPELIN/metainfo.xml

>      Line 72: 
> <osSpecific> 
>   <osFamily>redhat7,redhat6,redhat5,suse11</osFamily> 
>     <packages> 
>       <package> 
>         <name>gcc-gfortran</name> 
>       </package> 
>       <package> 
>         <name>blas-devel</name> 
>       </package> 
>       <package> 
>         <name>lapack-devel</name> 
>       </package> 
>       <package> 
>         <name>python-devel</name> 
>       </package> 
>       <package> 
>          <name>python-pip</name> 
>       </package> 
>       <package> 
>         <name>zeppelin</name> 
>       </package> 
>     </packages> 
> </osSpecific> 
> This list packages to install on SUSE11, but you don't find these packages on SUSE11
as they have different names than the RHEL ones... 
> Eg: 
> RHEL: gcc-gfortran 
> SUSE: gcc-fortran 
> RHEL: blas-devel 
> SUSE: libblas3 ? 
> RHEL: lapack-devel 
> SUSE: liblapack3 ? 
> RHEL: python-dev 
> SUSE: python-devel 
> RHEL: python-pip 
> SUSE: doesn't seem to be part of the standard repo 
> Solution: Make a custom <osSpecific></osSpecific> for SUSE 11, with the correct
named packages as they are named on SUSE 11
>  



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message