hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12879) Web authentication documentation is contradicting
Date Thu, 03 Mar 2016 16:19:18 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12879?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15178030#comment-15178030

Allen Wittenauer commented on HADOOP-12879:

I agree.  But we need to tread carefully here.

The Hadoop Auth guide is actually written from the perspective that it can be used by multiple
frameworks and live (mostly) independently.  So when it talks about e.g., PREFIX.kerberos.keytab
in the examples above, dfs.web.authentication is an example of a PREFIX.

> Web authentication documentation is contradicting
> -------------------------------------------------
>                 Key: HADOOP-12879
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12879
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: Wei-Chiu Chuang
>              Labels: authentication, documentation, webui
> Hi, I noticed recently folks are really focusing on documentation. (Kudos to +[~ajisakaa],
+[~brahmareddy], +[~iwasakims], +[~daisuke.kobayashi], +[~jzhuge] and more). 
> I've been following Hadoop documentation to set up web UI authentication, but it seems
to be contradicting between docs, for example, for web UI Kerberos keytab settings:
> * in _Hadoop in Secure Mode_ (SecureMode.md), HDFS daemons have distinct web UI authentication
configs, for example, for name node that's {{dfs.web.authentication.kerberos.keytab}},
> * but in _Authentication for Hadoop HTTP web-consoles_ (HttpAuthentication.md), it mentions
a Hadoop-wide config: {{hadoop.http.authentication.kerberos.keytab}}; 
> * finally, in _Hadoop Auth, Java HTTP SPNEGO - Server Side Configuration_(Configuration.md),
it says{{\[PREFIX.\]kerberos.principal}} should be used.
> They all seem to mean one thing, but different configuration names. So it's a bit of
confusing, or even contradicting to each other. Can we improve it?

This message was sent by Atlassian JIRA

View raw message