hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12857) Rework hadoop-tools-dist
Date Wed, 02 Mar 2016 20:32:18 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15176413#comment-15176413
] 

Allen Wittenauer commented on HADOOP-12857:
-------------------------------------------

bq. Would it make sense to leave these alone as special cases for now and defer improving
them to a separate patch? I think the primary benefit of this proposal is improved manageability
of the truly optional components.

Two things lead me to the answer no:

a) More than half of the bits in hadoop-tools are being called by a script.  (I know! it's
way more than I expected!)  The optional components are in the minority.

b) We'll definitely end up with duplicate jars in the classpath for those bits.  (The classpath
de-duper doesn't expand the asterisks.) 

But really, it's not that much extra just do it in one pass.  I'll likely have a patch in
the next day or so. (ofc, being unemployed helps haha)

> Rework hadoop-tools-dist
> ------------------------
>
>                 Key: HADOOP-12857
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12857
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 3.0.0
>            Reporter: Allen Wittenauer
>            Assignee: Allen Wittenauer
>
> As hadoop-tools grows bigger and bigger, it's becoming evident that having a single directory
that gets sucked in is starting to become a big burden as the number of tools grows.  Let's
rework this to be smarter.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message