hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11996) Native erasure coder facilities based on ISA-L
Date Fri, 26 Feb 2016 11:40:18 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11996?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15168859#comment-15168859
] 

Kai Zheng commented on HADOOP-11996:
------------------------------------

Hi [~cmccabe],

While working on the change, realized the following change may complicate the {{dynamic function
loading}} things, so I'm not sure about it now. I thought it's not a rare case that functions
defined in multiple *.h header files are implemented in a *.c source file. Maybe a better
name for {{erasure_code.c}} so it can contain those GF related functions as well? But I have
no idea what's the better.
bq. Put the functions described in gf_util.h in a source code file named gf_util.c, not in
erasure_code.c

Wdyt about this? Thanks.

> Native erasure coder facilities based on ISA-L
> ----------------------------------------------
>
>                 Key: HADOOP-11996
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11996
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: io
>            Reporter: Kai Zheng
>            Assignee: Kai Zheng
>         Attachments: HADOOP-11996-initial.patch, HADOOP-11996-v2.patch, HADOOP-11996-v3.patch,
HADOOP-11996-v4.patch, HADOOP-11996-v5.patch, HADOOP-11996-v6.patch, HADOOP-11996-v7.patch
>
>
> While working on HADOOP-11540 and etc., it was found useful to write the basic facilities
based on Intel ISA-L library separately from JNI stuff. It's also easy to debug and troubleshooting,
as no JNI or Java stuffs are involved.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message