hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11875) [JDK8] Renaming _ as a one-character identifier to another identifier
Date Mon, 01 Feb 2016 15:41:39 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11875?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15126413#comment-15126413

Steve Loughran commented on HADOOP-11875:

# Hamlet is easy to use from Java code. What do you want, us to switch to JSP?
# It's used in downstream YARN apps, which is not just done out of laziness, but to handle
the proxy renaming stuff, plus escaping of text.

Because of #2, Hamlet is going to have to stay around, even if something to replace it is
added alongside (or just pulled in from elsewhere)

> [JDK8] Renaming _ as a one-character identifier to another identifier
> ---------------------------------------------------------------------
>                 Key: HADOOP-11875
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11875
>             Project: Hadoop Common
>          Issue Type: Bug
>            Reporter: Tsuyoshi Ozawa
>              Labels: newbie
>         Attachments: build_error_dump.txt
> From JDK8, _ as a one-character identifier is disallowed. Currently Web UI uses it. We
should fix them to compile with JDK8. https://bugs.openjdk.java.net/browse/JDK-8061549

This message was sent by Atlassian JIRA

View raw message