hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12735) core-default.xml misspells hadoop.workaround.non.threadsafe.getpwuid
Date Tue, 26 Jan 2016 20:21:39 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12735?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15117912#comment-15117912
] 

Colin Patrick McCabe commented on HADOOP-12735:
-----------------------------------------------

Thanks, [~rchiang].  +1.

> core-default.xml misspells hadoop.workaround.non.threadsafe.getpwuid
> --------------------------------------------------------------------
>
>                 Key: HADOOP-12735
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12735
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.7.1
>            Reporter: Ray Chiang
>            Assignee: Ray Chiang
>            Priority: Minor
>              Labels: supportability
>         Attachments: HADOOP-12735.001.patch, HADOOP-12735.002.patch
>
>
> The property as defined in core-default.xml is
> bq.  hadoop.work.around.non.threadsafe.getpwuid
> But in NativeIO.java (the only place I can see a similar reference), the property is
defined as:
> bq.     static final String WORKAROUND_NON_THREADSAFE_CALLS_KEY = "hadoop.workaround.non.threadsafe.getpwuid";
> Note the extra period (.) in the word "workaround".
> Should the code be made to match the property or vice versa?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message