hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ray Chiang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-12735) Fix typo in core-default.xml property
Date Sat, 23 Jan 2016 16:16:39 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-12735?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ray Chiang updated HADOOP-12735:
--------------------------------
    Description: 
The property as defined in core-default.xml is

bq.  hadoop.work.around.non.threadsafe.getpwuid

But in NativeIO.java (the only place I can see a similar reference), the property is defined
as:

bq.     static final String WORKAROUND_NON_THREADSAFE_CALLS_KEY = "hadoop.workaround.non.threadsafe.getpwuid";

Note the extra period (.) in the word "workaround".

Should the code be made to match the property or vice versa?


  was:
The property as defined in core-default.xml is

bq.  hadoop.work.around.non.threadsafe.getpwuid

But in NativeIO.java (the only place I can see a similar reference), the property is defined
as:

bq.     static final String WORKAROUND_NON_THREADSAFE_CALLS_KEY =
      "hadoop.workaround.non.threadsafe.getpwuid";

Note the extra period (.) in the word "workaround".

Should the code be made to match the property or vice versa?



> Fix typo in core-default.xml property
> -------------------------------------
>
>                 Key: HADOOP-12735
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12735
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.8.0
>            Reporter: Ray Chiang
>            Assignee: Ray Chiang
>            Priority: Minor
>              Labels: supportability
>
> The property as defined in core-default.xml is
> bq.  hadoop.work.around.non.threadsafe.getpwuid
> But in NativeIO.java (the only place I can see a similar reference), the property is
defined as:
> bq.     static final String WORKAROUND_NON_THREADSAFE_CALLS_KEY = "hadoop.workaround.non.threadsafe.getpwuid";
> Note the extra period (.) in the word "workaround".
> Should the code be made to match the property or vice versa?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message