hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kihwal Lee (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12692) Maven's DependencyConvergence rule failed
Date Thu, 07 Jan 2016 14:44:39 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12692?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15087511#comment-15087511
] 

Kihwal Lee commented on HADOOP-12692:
-------------------------------------

Maybe this is causing the problem?
{noformat}
./hadoop-hdfs-project/hadoop-hdfs-httpfs/pom.xml:    <maven.build.timestamp.format>yyyy-MM-dd'T'HH:mm:ssZ</maven.build.timestamp.format>
./hadoop-hdfs-project/hadoop-hdfs-httpfs/pom.xml:    <httpfs.build.timestamp>${maven.build.timestamp}</httpfs.build.timestamp>
./hadoop-common-project/hadoop-nfs/pom.xml:    <maven.build.timestamp.format>yyyyMMdd</maven.build.timestamp.format>
./hadoop-common-project/hadoop-auth/pom.xml:    <maven.build.timestamp.format>yyyyMMdd</maven.build.timestamp.format>
{noformat}

> Maven's DependencyConvergence rule failed
> -----------------------------------------
>
>                 Key: HADOOP-12692
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12692
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>         Environment: Jenkins
>            Reporter: Wei-Chiu Chuang
>         Attachments: HADOOP-12692.001.patch
>
>
> I am seeing a Maven warning in Jenkins:
> https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/761/console
> This nightly job failed because of a Maven rule failed
> {noformat}
> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence failed with
message:
> Failed while enforcing releasability the error(s) are [
> Dependency convergence error for org.apache.hadoop:hadoop-auth:3.0.0-SNAPSHOT paths to
dependency are:
> +-org.apache.hadoop:hadoop-hdfs-httpfs:3.0.0-SNAPSHOT
>   +-org.apache.hadoop:hadoop-auth:3.0.0-SNAPSHOT
> and
> +-org.apache.hadoop:hadoop-hdfs-httpfs:3.0.0-SNAPSHOT
>   +-org.apache.hadoop:hadoop-common:3.0.0-SNAPSHOT
>     +-org.apache.hadoop:hadoop-auth:3.0.0-SNAPSHOT
> and
> +-org.apache.hadoop:hadoop-hdfs-httpfs:3.0.0-SNAPSHOT
>   +-org.apache.hadoop:hadoop-common:3.0.0-SNAPSHOT
>     +-org.apache.hadoop:hadoop-auth:3.0.0-SNAPSHOT
> and
> +-org.apache.hadoop:hadoop-hdfs-httpfs:3.0.0-SNAPSHOT
>   +-org.apache.hadoop:hadoop-auth:3.0.0-20160107.005725-7960
> ]
> {noformat}
> {noformat}
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:1.3.1:enforce
(depcheck) on project hadoop-hdfs-httpfs: Some Enforcer rules have failed. Look above for
specific messages explaining why the rule failed. -> [Help 1]
> {noformat}
> Looks like httpfs depends on two versions of hadoop-auth: 3.0.0-SNAPSHOT and a timestamp
based.
> I think this can be fixed by updating one of the pom.xml files. But I am not exactly
sure how to do it. Need a Maven expert here.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message