hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12651) Replace dev-support with wrappers to Yetus
Date Thu, 21 Jan 2016 21:56:39 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12651?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15111372#comment-15111372
] 

Hudson commented on HADOOP-12651:
---------------------------------

FAILURE: Integrated in Hadoop-trunk-Commit #9156 (See [https://builds.apache.org/job/Hadoop-trunk-Commit/9156/])
HADOOP-12651. Replace dev-support with wrappers to Yetus (aw) (aw: rev 8cecad2d564d89d0f56e98de80a6f9b0bcb39d7a)
* dev-support/smart-apply-patch.sh
* hadoop-common-project/hadoop-common/pom.xml
* BUILDING.txt
* dev-support/test-patch.d/shellcheck.sh
* dev-support/test-patch.sh
* dev-support/test-patch.d/checkstyle.sh
* dev-support/test-patch.d/whitespace.sh
* dev-support/shelldocs.py
* dev-support/releasedocmaker.py
HADOOP-12651. Replace dev-support with wrappers to Yetus (aw) (aw: rev 2a867355dfce880bb82257508862ec26bc7f16b9)
* dev-support/README.md
* dev-support/bin/test-patch
* dev-support/bin/releasedocmaker
* dev-support/bin/shelldocs
* dev-support/bin/yetus-wrapper
* dev-support/bin/smart-apply-patch


> Replace dev-support with wrappers to Yetus
> ------------------------------------------
>
>                 Key: HADOOP-12651
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12651
>             Project: Hadoop Common
>          Issue Type: New Feature
>          Components: scripts
>    Affects Versions: 3.0.0
>            Reporter: Allen Wittenauer
>            Assignee: Allen Wittenauer
>             Fix For: 3.0.0
>
>         Attachments: HADOOP-12651.00.patch, HADOOP-12651.01.patch, HADOOP-12651.02.patch,
HADOOP-12651.03.patch, HADOOP-12651.04.patch
>
>
> Now that Yetus has had a release, we should rip out the components that make it up from
dev-support and replace them with wrappers.  The wrappers should:
> * default to a sane version
> * allow for version overrides via an env var
> * download into patchprocess
> * execute with the given parameters
> Marking this as an incompatible change, since we should also remove the filename extensions
and move these into a bin directory for better maintenance towards the future.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message