hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12647) Allowing to use -Drequire.isal but without -Disal.prefix and -Disal.lib to build ISA-L support
Date Wed, 16 Dec 2015 08:57:46 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12647?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15059720#comment-15059720
] 

Kai Zheng commented on HADOOP-12647:
------------------------------------

Tested the changes as follows:
* Case 1. Build with default ISA-L installation
** Installing ISA-L to /usr/lib the default folder the library uses
** mvn build hadoop using -Drequire.isal option only, run {{mvn -Pnative package -Drequire.isal
-DskipTests -Pdist}} passed
* Case 2. Build with customized ISA-L installation
** Installing ISA-L to a custom folder like /tmp/isal
** mvn build hadoop using the installation, run {{mvn -Pnative package -Drequire.isal -Disal.prefix=/tmp/isal
-DskipTests -Pdist}} passed
* Case 3. Build tar dist package with customized ISA-L installaton
** Installing ISA-L to a custom folder like /tmp/isal
** mvn build hadoop using the installation, run {{mvn -Pnative package -Drequire.isal -Disal.lib=/tmp/isal
-Dbundle.isal -DskipTests -Pdist -Dtar}} passed
** Checked the result tar package is valid and contains ISA-L library files
In all cases, run {{hadoop checknative}} passed.
Also tested negative cases.

> Allowing to use -Drequire.isal but without -Disal.prefix and -Disal.lib to build ISA-L
support
> ----------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-12647
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12647
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: Kai Zheng
>            Assignee: Kai Zheng
>         Attachments: HADOOP-12647-v1.patch
>
>
> It was found the building will fail when use -Drequire.isal only (without -Disal.prefix
and -Disal.lib options) to build ISA-L in order to use the default library installation. The
cause is the mvn executor doesn't know where to find the dynamic so file.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message