hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9822) create constant MAX_CAPACITY in RetryCache rather than hard-coding 16 in RetryCache constructor
Date Mon, 23 Nov 2015 22:23:11 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15023218#comment-15023218
] 

Hudson commented on HADOOP-9822:
--------------------------------

FAILURE: Integrated in Hadoop-Mapreduce-trunk #2647 (See [https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2647/])
HADOOP-9822. create constant MAX_CAPACITY in RetryCache rather than (wheat9: rev 5f269a0ad81bb6abc5242bf628f028ae6812f6b3)
* hadoop-common-project/hadoop-common/CHANGES.txt
* hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/RetryCache.java


> create constant MAX_CAPACITY in RetryCache rather than hard-coding 16 in RetryCache constructor
> -----------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-9822
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9822
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.3.0
>            Reporter: Tsuyoshi Ozawa
>            Assignee: Tsuyoshi Ozawa
>            Priority: Minor
>              Labels: BB2015-05-TBR
>             Fix For: 2.8.0
>
>         Attachments: HADOOP-9822.1.patch, HADOOP-9822.2.patch, HADOOP-9822.3.patch, HADOOP-9822.4.patch
>
>
> The magic number "16" is also used in ClientId.BYTE_LENGTH, so hard-coding magic number
"16" is a bit confusing.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message