hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12478) Shell.getWinUtilsPath() has been renamed Shell.getWinutilsPath()
Date Wed, 14 Oct 2015 23:08:06 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12478?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14957980#comment-14957980
] 

Hudson commented on HADOOP-12478:
---------------------------------

SUCCESS: Integrated in Hadoop-Yarn-trunk #1267 (See [https://builds.apache.org/job/Hadoop-Yarn-trunk/1267/])
HADOOP-12478. Shell.getWinUtilsPath() has been renamed (stevel: rev dfa78484633b3ce21471d527b9c24671e3ca5df9)
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/WindowsSecureContainerExecutor.java
* hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestShell.java
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/ContainerExecutor.java
* hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/security/TestUserGroupInformation.java
* hadoop-common-project/hadoop-common/CHANGES.txt
* hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/NativeLibraryChecker.java
* hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/SysInfoWindows.java
* hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestWinUtils.java
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-common/src/main/java/org/apache/hadoop/yarn/util/WindowsBasedProcessTree.java
* hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Shell.java
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/launcher/ContainerLaunch.java
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/test/java/org/apache/hadoop/yarn/server/nodemanager/containermanager/launcher/TestContainerLaunch.java
* hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/HardLink.java


> Shell.getWinUtilsPath()  has been renamed Shell.getWinutilsPath() 
> ------------------------------------------------------------------
>
>                 Key: HADOOP-12478
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12478
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: util
>    Affects Versions: 2.8.0
>            Reporter: Steve Loughran
>            Assignee: Steve Loughran
>            Priority: Critical
>             Fix For: 2.8.0
>
>         Attachments: HADOOP-12478-001.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> The shell enhancements of HADOOP-10775 managed to unintentionally change {{Shell.getWinUtilsPath()}}
 has been renamed {{Shell.getWinutilsPath()}}. This didn't crop in Hadoop's code, but it's
broken some of my stuff downstream -stuff in Groovy which the IDE didn't pick up as a regression.
> I'll fix things by renaming the method to its original name, and changing the name of
the {{getWinutilsFile()}} to match



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message