hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-12478) Shell.getWinUtilsPath() has been renamed Shell.getWinutilsPath()
Date Wed, 14 Oct 2015 19:21:05 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-12478?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Chris Nauroth updated HADOOP-12478:
    Hadoop Flags: Reviewed

+1 for the patch.  The pre-existing Findbugs warning is unrelated.  Thank you, Steve.

I'm still really loving those shorter hadoop-common test run times.  :-)

> Shell.getWinUtilsPath()  has been renamed Shell.getWinutilsPath() 
> ------------------------------------------------------------------
>                 Key: HADOOP-12478
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12478
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: util
>    Affects Versions: 2.8.0
>            Reporter: Steve Loughran
>            Assignee: Steve Loughran
>            Priority: Critical
>         Attachments: HADOOP-12478-001.patch
>   Original Estimate: 1h
>  Remaining Estimate: 1h
> The shell enhancements of HADOOP-10775 managed to unintentionally change {{Shell.getWinUtilsPath()}}
 has been renamed {{Shell.getWinutilsPath()}}. This didn't crop in Hadoop's code, but it's
broken some of my stuff downstream -stuff in Groovy which the IDE didn't pick up as a regression.
> I'll fix things by renaming the method to its original name, and changing the name of
the {{getWinutilsFile()}} to match

This message was sent by Atlassian JIRA

View raw message