hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12065) Using more meaningful keys in EC schema
Date Wed, 30 Sep 2015 17:49:29 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12065?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14938120#comment-14938120
] 

Hudson commented on HADOOP-12065:
---------------------------------

FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #439 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/439/])
HADOOP-12065 Using more meaningful keys in EC schema. Contributed by Kai (kai.zheng: rev c41b02cc0058239657263d45d969e71b14e6a589)
* hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/io/erasurecode/ECSchema.java
* hadoop-common-project/hadoop-common/CHANGES-HDFS-EC-7285.txt
* hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/io/erasurecode/TestSchemaLoader.java


> Using more meaningful keys in EC schema
> ---------------------------------------
>
>                 Key: HADOOP-12065
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12065
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: io
>            Reporter: Kai Zheng
>            Assignee: Kai Zheng
>         Attachments: HADOOP-12065-HDFS-7285-v1.patch
>
>
> Commented by [~szetszwo] in HADOOP-12029:
> bq. We should also change "k" and "m" in the following to something like "numDataUnits"
and "numParityUnits".
> {code}
>    public static final String NUM_DATA_UNITS_KEY = "k";
>    public static final String NUM_PARITY_UNITS_KEY = "m";
> {code}
> This sounds good to me, as in fact in many erasure coding related papers, discussions,
and implementations, though {{k}} and {{m}} are broadly used, the meanings are not consistent.
For example, {{m}} can also mean {{numDataUnits + numParityUnits}}, all the rows in the coding
matrix. The suggested names are more clear and explicit.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message