hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Inigo Goiri (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-12180) Move ResourceCalculatorPlugin from YARN to Common
Date Mon, 06 Jul 2015 18:58:05 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-12180?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14615478#comment-14615478

Inigo Goiri commented on HADOOP-12180:

* I think that the SysInfo name is not as meaningful as ResourceCalculator but I don't have
better proposals so I guess is fine
* Can we add HDFS to LimitedPrivate in SysInfo?
* What about making ResourceCalculatorPlugin extend/implement SysInfo to make the dependency
more clear? This would also change the initialization of the other plugins and may not work.
* +1 on threadsafety, I think is worth doing; not sure if here or in a separate JIRA.

> Move ResourceCalculatorPlugin from YARN to Common
> -------------------------------------------------
>                 Key: HADOOP-12180
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12180
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: util
>            Reporter: Chris Douglas
>            Assignee: Chris Douglas
>         Attachments: HADOOP-12180.000.patch, HADOOP-12180.001.patch
> Some of the monitoring functions could be moved from YARN to Common for easier sharing

This message was sent by Atlassian JIRA

View raw message