hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kengo Seki (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-11903) test-patch plugin for checking file name conventions
Date Wed, 08 Jul 2015 11:59:04 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-11903?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Kengo Seki updated HADOOP-11903:
    Attachment: HADOOP-11903.HADOOP-12111.01.patch

Attaching a wip patch

> test-patch plugin for checking file name conventions
> ----------------------------------------------------
>                 Key: HADOOP-11903
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11903
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: yetus
>    Affects Versions: HADOOP-12111
>            Reporter: Allen Wittenauer
>            Assignee: Kengo Seki
>         Attachments: HADOOP-11903.HADOOP-12111.00.patch, HADOOP-11903.HADOOP-12111.01.patch
> Providing yetus with the functionality to detect newly added files which doesn't follow
the naming conventions. As for java, it also can be used for checking classnames. In the past,
we've named things like DefaultResourceCalculator, DefaultContainerExecutor, and DefaultCodec
that do nothing but cause problems down the road since they are effectively version and functionality
locked forever.  If these examples had been named what they truly were (e.g., MemoryResourceCalculator,
SimpleContainerExecutor, and GZipCodec), the defaults could then be changed in the future
in a compatible way. One way to enforce this is to prevent the creation of new classes called

This message was sent by Atlassian JIRA

View raw message