hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11993) maven enforcer plugin to ban java 8 incompatible dependencies
Date Mon, 18 May 2015 15:35:03 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11993?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14548172#comment-14548172
] 

Sean Busbey commented on HADOOP-11993:
--------------------------------------

When adding this, it'd be easier to maintain if we included a comment that referenced an upstream
issue for dependencies that are banned without a version range.

> maven enforcer plugin to ban java 8 incompatible dependencies
> -------------------------------------------------------------
>
>                 Key: HADOOP-11993
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11993
>             Project: Hadoop Common
>          Issue Type: Sub-task
>    Affects Versions: 2.7.0
>            Reporter: Steve Loughran
>            Priority: Minor
>
> It's possible to use maven-enforcer to ban dependencies; this can be used to reject those
known to be incompatible with Java 8
> [example|https://gist.github.com/HiJon89/65e34552c18e5ac9fd31]
> If we set maven enforcer to do this checking, it can ensure that the 2.7+ codebase isn't
pulling in any incompatible binaries.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message