hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Sivachenko (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11927) libcrypto needs libdl when compile native code
Date Wed, 06 May 2015 09:44:59 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11927?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14530258#comment-14530258
] 

Dmitry Sivachenko commented on HADOOP-11927:
--------------------------------------------

Don't forget other OSes (like FreeBSD) which do not have libdl at all (dlopen() is in libc)

> libcrypto needs libdl when compile native code
> ----------------------------------------------
>
>                 Key: HADOOP-11927
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11927
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: tools
>         Environment: SUSE Linux Enterprise Server 11 SP3  (x86_64)
>            Reporter: Xianyin Xin
>            Assignee: Xianyin Xin
>         Attachments: HADOOP-11927-001.patch
>
>
> When compile hadoop with native support, we encounter compile error that "undefined reference
to `dlopen'" when link libcrypto. We'd better link libdl explicitly in CMakeList of hadoop-pips.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message