hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-11927) libhadooppipes needs libdl when using libcrypto
Date Fri, 22 May 2015 19:50:17 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-11927?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Colin Patrick McCabe updated HADOOP-11927:
------------------------------------------
    Summary: libhadooppipes needs libdl when using libcrypto  (was: libcrypto needs libdl
when compile native code)

> libhadooppipes needs libdl when using libcrypto
> -----------------------------------------------
>
>                 Key: HADOOP-11927
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11927
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build, native, tools
>         Environment: SUSE Linux Enterprise Server 11 SP3  (x86_64)
>            Reporter: Xianyin Xin
>            Assignee: Xianyin Xin
>         Attachments: HADOOP-11927-001.patch, HADOOP-11927-002.patch
>
>
> When compile hadoop with native support, we encounter compile error that "undefined reference
to `dlopen'" when link libcrypto. We'd better link libdl explicitly in CMakeList of hadoop-pips.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message