hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-8793) hadoop-core has dependencies on two different versions of commons-httpclient
Date Sat, 02 May 2015 04:35:10 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-8793?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14524731#comment-14524731
] 

Hadoop QA commented on HADOOP-8793:
-----------------------------------

\\
\\
| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:red}-1{color} | patch |   0m  0s | The patch command could not apply the patch during
dryrun. |
\\
\\
|| Subsystem || Report/Notes ||
| Patch URL | http://issues.apache.org/jira/secure/attachment/12581868/HADOOP-8793.patch |
| Optional Tests | javadoc javac unit |
| git revision | trunk / f1a152c |
| Console output | https://builds.apache.org/job/PreCommit-HADOOP-Build/6317/console |


This message was automatically generated.

> hadoop-core has dependencies on two different versions of commons-httpclient
> ----------------------------------------------------------------------------
>
>                 Key: HADOOP-8793
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8793
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.20.205.0
>         Environment: Seen on 0.20.205.0, but may be an issue for other versions of hadoop-core
(and probably other hadoop builds)
>            Reporter: Christopher Tubbs
>            Priority: Critical
>              Labels: convergence, dependency, hadoop, httpclient, maven
>         Attachments: HADOOP-8793.patch
>
>
> hadoop-core fails to enforce dependency convergence, resulting in potential conflicts.
> At the very least, there appears to be a direct dependency on
> {code}commons-httpclient:commons-httpclient:3.0.1{code}
> but a transitive dependency on
> {code}commons-httpclient:commons-httpclient:3.1{code}
> via
> {code}net.java.dev.jets3t:jets3t:0.7.1{code}
> See http://maven.apache.org/enforcer/enforcer-rules/dependencyConvergence.html for details
on how to enforce dependency convergence in Maven.
> Please enforce dependency convergence... it helps projects that depend on hadoop libraries
build much more reliably and safely.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message