hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11876) Refactor code to make it more readable, minor maybePrintStats bug
Date Sat, 25 Apr 2015 15:35:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11876?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14512560#comment-14512560
] 

Hudson commented on HADOOP-11876:
---------------------------------

SUCCESS: Integrated in Hadoop-Mapreduce-trunk #2124 (See [https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2124/])
HADOOP-11876. Refactor code to make it more readable, minor maybePrintStats bug (Zoran Dimitrijevic
via raviprak) (raviprak: rev a287d2fb77d9873b61c6ab24134993d784ae8475)
* hadoop-common-project/hadoop-common/CHANGES.txt
* hadoop-tools/hadoop-distcp/src/main/java/org/apache/hadoop/tools/SimpleCopyListing.java


> Refactor code to make it more readable, minor maybePrintStats bug
> -----------------------------------------------------------------
>
>                 Key: HADOOP-11876
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11876
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: tools/distcp
>    Affects Versions: 3.0.0
>            Reporter: Zoran Dimitrijevic
>            Assignee: Zoran Dimitrijevic
>            Priority: Trivial
>             Fix For: 2.8.0
>
>         Attachments: HADOOP-11876.patch
>
>
> This is related to HADOOP-11827 patch from few days ago. I've noticed a minor bug in
maybePrintStats logic which is called only when new directory is processed, and prints every
100K objects (effectively, there is a very low probability it'll ever print stats). The reason
for this bug is that I was previously printing stats for every new directory, and later decided
it's nicer to print stats for large number of new "objects" (files or directories) instead.

> This is a minor issue - and since I'm refactoring this I've also changed the minor retry
logic to make code nicer and more readable.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message