hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jakob Homan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11850) Typos in hadoop-common java docs
Date Mon, 20 Apr 2015 21:18:01 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11850?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14503658#comment-14503658
] 

Jakob Homan commented on HADOOP-11850:
--------------------------------------

{noformat}--- a/hadoop-common-project/hadoop-auth/src/main/java/org/apache/hadoop/security/authentication/server/AltKerberosAuthenticationHandler.java
+++ b/hadoop-common-project/hadoop-auth/src/main/java/org/apache/hadoop/security/authentication/server/AltKerberosAuthenticationHandler.java
@@ -25,7 +25,7 @@
  * The {@link AltKerberosAuthenticationHandler} behaves exactly the same way as
  * the {@link KerberosAuthenticationHandler}, except that it allows for an
  * alternative form of authentication for browsers while still using Kerberos
- * for Java access.  This is an abstract class that should be subclassed
+ * for Java access.  This is an abstract class that should be subclasses{noformat}
subclassed here is correct, as it's being used a verb.

{noformat}+++ b/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/BufferedFSInputStream.java
@@ -27,7 +27,7 @@


 /**
- * A class optimizes reading from FSInputStream by bufferring
+ * A class optimizes reading from FSInputStream by buffering
  */{noformat}
Should be a {{a class that optimizes}} as well as your correction.

{noformat}+++ b/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
@@ -254,7 +254,7 @@ private int maxLength(int n, Object value) {
   }

   /**
-   * Initialise the comparator to be used for sorting files. If multiple options
+   * Initialize the comparator to be used for sorting files. If multiple options{noformat}
Initialise is a valid British/Australian/Canadian/NewZealish spelling variant.  I believe
we had a discussion many years ago and agreed to let variants in wherever the original author
preferred them.

Otherwise, looks good.

> Typos in hadoop-common java docs
> --------------------------------
>
>                 Key: HADOOP-11850
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11850
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.6.0
>            Reporter: surendra singh lilhore
>            Assignee: surendra singh lilhore
>            Priority: Minor
>         Attachments: HADOOP-11850.patch
>
>
> This jira will fix the typo in hdfs-common project



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message