hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11846) TestCertificateUtil.testCorruptPEM failing on Jenkins
Date Sat, 18 Apr 2015 10:56:59 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11846?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14501254#comment-14501254
] 

Steve Loughran commented on HADOOP-11846:
-----------------------------------------

{code}
Error Message

Input byte array has wrong 4-byte ending unit
Stacktrace

java.lang.IllegalArgumentException: Input byte array has wrong 4-byte ending unit
	at java.util.Base64$Decoder.decode0(Base64.java:704)
	at java.util.Base64$Decoder.decode(Base64.java:526)
	at java.util.Base64$Decoder.decode(Base64.java:549)
	at sun.security.provider.X509Factory.readOneBlock(X509Factory.java:578)
	at sun.security.provider.X509Factory.engineGenerateCertificate(X509Factory.java:93)
	at java.security.cert.CertificateFactory.generateCertificate(CertificateFactory.java:339)
	at org.apache.hadoop.security.authentication.util.CertificateUtil.parseRSAPublicKey(CertificateUtil.java:49)
	at org.apache.hadoop.security.authentication.util.TestCertificateUtil.testCorruptPEM(TestCertificateUtil.java:67)
{code}

> TestCertificateUtil.testCorruptPEM failing on Jenkins
> -----------------------------------------------------
>
>                 Key: HADOOP-11846
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11846
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build, security
>    Affects Versions: 3.0.0
>            Reporter: Steve Loughran
>
> Jenkins is failing on {{TestCertificateUtil.testCorruptPEM}}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message