hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-11805) Better to rename some raw erasure coders
Date Fri, 03 Apr 2015 23:01:52 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-11805?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kai Zheng updated HADOOP-11805:
-------------------------------
    Attachment: HADOOP-11805-v1.patch

Uploaded a patch performing some renaming.

> Better to rename some raw erasure coders
> ----------------------------------------
>
>                 Key: HADOOP-11805
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11805
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: io
>            Reporter: Kai Zheng
>            Assignee: Kai Zheng
>         Attachments: HADOOP-11805-v1.patch
>
>
> When work on more coders, it was found better to rename some existing raw coders for
consistency, and more meaningful. As a result, we may have:
> XORRawErasureCoder, in Java
> NativeXORRawErasureCoder, in native
> RSRawErasureCoder, in Java
> NativeRSRawErasureCoder, in native and using ISA-L



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message