hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11789) NPE in TestCryptoStreamsWithOpensslAesCtrCryptoCodec
Date Wed, 08 Apr 2015 20:52:13 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11789?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14486003#comment-14486003
] 

Colin Patrick McCabe commented on HADOOP-11789:
-----------------------------------------------

bq. Colin, if -Pnative is set, but the os doesn't have a correct version of OpenSSL, then
we should make the test failed.

Yes.  Absolutely.

We've had some very subtle bugs earlier where we thought we were testing the openssl integration,
but we actually were not. This is because there was a very subtle difference in the version
of openssl installed on the jenkins machine and the one we needed.

I think the highest priority here is to make sure our Jenkins coverage doesn't regress again.
 If people running tests locally want to skip the native tests, they can simply run the test
suite without {{\-Pnative}}, or skip running the openssl test.

I think we should just close this as WONTFIX, what do you think?

> NPE in TestCryptoStreamsWithOpensslAesCtrCryptoCodec 
> -----------------------------------------------------
>
>                 Key: HADOOP-11789
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11789
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.0.0, 2.8.0
>         Environment: ASF Jenkins
>            Reporter: Steve Loughran
>            Assignee: Yi Liu
>         Attachments: HADOOP-11789.001.patch
>
>
> NPE surfacing in {{TestCryptoStreamsWithOpensslAesCtrCryptoCodec}} on  Jenkins



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message