hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsuyoshi Ozawa (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-10105) remove httpclient dependency
Date Wed, 25 Feb 2015 07:38:04 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10105?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14336154#comment-14336154
] 

Tsuyoshi Ozawa commented on HADOOP-10105:
-----------------------------------------

[~ajisakaa] [~brahmareddy] Thank you for taking these issues. I have one question : what versions
are you targeting? If we do this, the timing of upgrading should be at the same time since
it's not good idea to use mixed libraries of http clients. I looked some related tickets,
and some resolved issues are targeting 2.7.0. Is it possible to remove all dependency at 2.7.0
release? If not, I think it's better to target 2.8.0 release.

> remove httpclient dependency
> ----------------------------
>
>                 Key: HADOOP-10105
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10105
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Colin Patrick McCabe
>            Assignee: Akira AJISAKA
>            Priority: Minor
>         Attachments: HADOOP-10105.2.patch, HADOOP-10105.part.patch, HADOOP-10105.part2.patch,
HADOOP-10105.patch
>
>
> httpclient is now end-of-life and is no longer being developed.  Now that we have a dependency
on {{httpcore}}, we should phase out our use of the old discontinued {{httpclient}} library
in Hadoop.  This will allow us to reduce {{CLASSPATH}} bloat and get updated code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message