hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vijay Bhat (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9329) document native build dependencies in BUILDING.txt
Date Tue, 10 Feb 2015 19:06:12 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9329?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14314679#comment-14314679
] 

Vijay Bhat commented on HADOOP-9329:
------------------------------------

I've built hadoop with native code on Ubuntu 14.04 LTS. Rick is correct that the Windows requirements
section in BUILDING.txt addresses the native libraries needed. The only software / libraries
I needed to install are:

* Java 1.7
* Maven 3.0.5
* Protobuf-2.5.0
* CMake 2.8.12.2
 
The command I ran for compiling native code was 

  mvn clean package -Pdist -DskipTests -Pnative

[~cmccabe], do you think I should add a section to BUILDING.txt that goes over requirements
for building on Ubuntu? Or do you think we should close out this issue as is?

> document native build dependencies in BUILDING.txt
> --------------------------------------------------
>
>                 Key: HADOOP-9329
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9329
>             Project: Hadoop Common
>          Issue Type: Task
>          Components: documentation
>    Affects Versions: 2.1.0-beta
>            Reporter: Colin Patrick McCabe
>            Assignee: Vijay Bhat
>            Priority: Trivial
>
> {{BUILDING.txt}} describes {{-Pnative}}, but it does not specify what native libraries
are needed for the build.  We should address this.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message