hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-9402) Ivy dependencies don't declare that commons-net is a core dependency
Date Tue, 27 Jan 2015 10:02:35 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-9402?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Steve Loughran updated HADOOP-9402:
-----------------------------------
    Resolution: Won't Fix
      Assignee: Steve Loughran
        Status: Resolved  (was: Patch Available)

> Ivy dependencies don't declare that commons-net is a core dependency
> --------------------------------------------------------------------
>
>                 Key: HADOOP-9402
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9402
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.2.0
>            Reporter: Steve Loughran
>            Assignee: Steve Loughran
>            Priority: Minor
>         Attachments: HADOOP-9402.patch
>
>
> HDFS-3148 changed {{NetUtils}} to use commons-net components, and in doing so
> added a dependency on commons-net into the core JARs. Previously it was only declared
as a dependency for the {{ftp}} and {{s3-client}} configs. 
> This impacts local ivy builds more than anything else. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message