hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-10049) 2.1.0 beta won't run under cygwin?
Date Mon, 15 Dec 2014 23:32:13 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-10049?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Allen Wittenauer updated HADOOP-10049:
--------------------------------------
    Fix Version/s:     (was: 2.1.0-beta)

> 2.1.0 beta won't run under cygwin?
> ----------------------------------
>
>                 Key: HADOOP-10049
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10049
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: bin
>    Affects Versions: 2.1.1-beta
>         Environment: windows xp + cygwin
>            Reporter: Michael Klybor
>
> I recently tried out 2.1.0 beta in the hope of benefiting from numerous improvements
made re: running on cygwin. I cannot even get a "bin/hadoop version" to work, it gets a java.lang.NoClassDefFoundError
for the common classes such as org.apache.hadoop.util.VersionInfo
> I've looked a similiar bug report and have made sure that HADOOP_PREFIX is set, and that
HADOOP_HOME is not set. I've looked at the output of "bin/hadoop classpath" and it looks correct
EXCEPT that 2.1.0 shows the classpath using unix syntax and paths, while my older version
of hadoop (1.2.1) shows it using Windows syntax and paths.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message