hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harsh J (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-7947) Validate XMLs if a relevant tool is available, when using scripts
Date Sun, 14 Dec 2014 17:40:13 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-7947?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Harsh J updated HADOOP-7947:
----------------------------
    Target Version/s:   (was: 0.24.0)

> Validate XMLs if a relevant tool is available, when using scripts
> -----------------------------------------------------------------
>
>                 Key: HADOOP-7947
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7947
>             Project: Hadoop Common
>          Issue Type: Wish
>          Components: scripts
>    Affects Versions: 2.7.0
>            Reporter: Harsh J
>              Labels: newbie
>
> Given that we are locked down to using only XML for configuration and most of the administrators
need to manage it by themselves (unless a tool that manages for you is used), it would be
good to also validate the provided config XML (*-site.xml) files with a tool like {{xmllint}}
or maybe Xerces somehow, when running a command or (at least) when starting up daemons.
> We should use this only if a relevant tool is available, and optionally be silent if
the env. requests.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message