hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun C Murthy (JIRA)" <j...@apache.org>
Subject [jira] [Moved] (HADOOP-11286) Map/Reduce dangerously adds Guava @Beta class to CryptoUtils
Date Sat, 08 Nov 2014 23:37:34 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-11286?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arun C Murthy moved MAPREDUCE-6083 to HADOOP-11286:
---------------------------------------------------

     Target Version/s: 2.6.0  (was: 3.0.0, 2.6.0, 2.7.0)
    Affects Version/s:     (was: 2.6.0)
                       2.6.0
                  Key: HADOOP-11286  (was: MAPREDUCE-6083)
              Project: Hadoop Common  (was: Hadoop Map/Reduce)

> Map/Reduce dangerously adds Guava @Beta class to CryptoUtils
> ------------------------------------------------------------
>
>                 Key: HADOOP-11286
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11286
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 2.6.0
>            Reporter: Christopher Tubbs
>            Priority: Blocker
>              Labels: beta, deprecated, guava
>         Attachments: 0001-MAPREDUCE-6083-Avoid-client-use-of-deprecated-LimitI.patch,
0001-MAPREDUCE-6083-and-HDFS-7040-Avoid-Guava-s-LimitInpu.patch
>
>
> See HDFS-7040 for more background/details.
> In recent 2.6.0-SNAPSHOTs, the use of LimitInputStream was added to CryptoUtils. This
is part of the API components of Hadoop, which severely impacts users who were utilizing newer
versions of Guava, where the @Beta and @Deprecated class, LimitInputStream, has been removed
(removed in version 15 and later), beyond the impact already experienced in 2.4.0 as identified
in HDFS-7040.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message